S10 Forums

Go Back   S10 Forums > Specific Models > 1st Generation

Reply
 
Thread Tools Display Modes
  #1  
Old 07-08-2009, 12:01 AM
ryansgonewayward
Guest
 
Posts: n/a
Question 92 s10 pu 4.3L FI

just bought my first fi its running kind of rough right now. went out and got a radiator for it and is running better. HOWEVER this problem im having isnt going away im thinking a new feul filter or air filter. when i try and gun the gas and floor it on the freeway or to right turn a red. the engine kinda "bogs" by that i mean it dies for a second and then catches again. any possiblities that a fuel filter or an air filter could fix this.
Reply With Quote
  #2  
Old 07-08-2009, 01:22 AM
AaronK's Avatar
AaronK AaronK is offline
Senior Member
 
Join Date: Oct 2008
Location: Tacoma, WA but my heart's in TX
Posts: 1,313
Default

Well you can look at your air filter and easily determine if you need a new one or not.
Definitely sounds like it could be a fuel filter problem though. Couldn't hurt to replace.
__________________
-Aaron
2001 ZR2
http://www.cardomain.com/ride/3213485

"We sleep safe in our beds because rough men stand ready in the night to visit violence on those who would do us harm." - George Orwell

ZR2: The official recovery vehicle of Jeep.
Reply With Quote
  #3  
Old 07-08-2009, 07:08 AM
Cyanide Jello's Avatar
Cyanide Jello Cyanide Jello is offline
Moderator
 
Join Date: Oct 2008
Location: Roanoke, Va
Posts: 3,902
Default

I vote full tune up...
__________________
Team Speedbump
Battlestags

Current - 90 Hoodride CRX Si boosted d16z6
Sold - 89 EF hatch - Sold - built D16Z6T 98 EK Civic - Traded - Shav'd and Bag'd 94 S10 - Sold - Slam'd 91 s10 - Sold - 85 Skyhawk 2.0t
[/font]
Reply With Quote
  #4  
Old 07-08-2009, 08:35 AM
ChaosWorks's Avatar
ChaosWorks ChaosWorks is offline
Senior Member
 
Join Date: Oct 2008
Location: Vinton, IA
Posts: 995
Default

Poor spark will also cause that. I'd check the spark plugs, wires, etc first.
I second the vote for a full tune up.
__________________
On/Off road warrior
92 4.3L ext cab 4x4 Sonoma, NV4500+NP242, full brush/grill guard, Powertrax locker, Optima yellow top, Zena 200A welder/alternator, Kenwood excelon: deck, amps, speakers, and music keg.
Quote:
Originally Posted by twin_rotor View Post
lol I thought you were an engineer, but you're also a google whore.
Reply With Quote
  #5  
Old 07-08-2009, 10:21 AM
wedebrook wedebrook is offline
Member
 
Join Date: May 2009
Location: Chillicothe, Ohio
Posts: 43
Default

if you have a catalytic converter that is starting to clog, it could do that too.
__________________
1991 Chevrolet S10 4.3L 4x4
2005 Chevrolet Trailblazer 4.2L 4x4
2000 Chevrolet Impala 3400
Reply With Quote
  #6  
Old 07-08-2009, 05:18 PM
lxtasy's Avatar
lxtasy lxtasy is offline
Senior Member
 
Join Date: Jan 2009
Location: Summerville, SC
Posts: 496
Send a message via AIM to lxtasy
Default

On the FULL TUNE up replace the fuel pressure regulator , injectors and see if that doesn't fix it. Could also be the map sensor as well. That is the problem when buying a used vehicle with some wear and tear on it. My 90 ran like crap when I first got it with lots of problems and when i did the full tune up replacing everything it seems it runs thousand times better than most tbis.
__________________
Toy:
1989 black s-15 with little 355sbc SOLD

Daily:
1990 Doo Doo brown blazer with baby 4.3. 3/3 drop and misc mods GONE

04 ecsb silverado Wifes NEW daily.

1998 4.3 4door 2wd. Fresh motor rebuilt solo, mild built 4l60e by transmission expert friend.

1993 nissan mini with ka24 and stock for now...4wheeler and side job hauler
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:34 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.